MOO-cows Mailing List Archive


Suggestions and requests for listen()

Now that I'm testing it out, I see why everyone likes MPL so much.  However,
I have a request (fervent plea):

Although we now have the ability to listen() to ports with object other
than #0, the connection messages still come from $server_options.  However,
I think it makes sense to let the listen()ing object decide what messages
to use -- for example, Web users need different messages (HTML-escaped, or
whatever) than ordinary users receive -- and now we could easily do this,
if only the listen()ing object had the choice of which messages to send to
the connection.

Please, please, make listen(OBJECT, DESC, 1) use not only it own verbs like
OBJECT:do_login_command(), etc., but also its own properties, like
OBJECT.server_options.connection_msg, etc. instead of

In fact, a better naming scheme might be in order, perhaps dropping
the "server" and just using OBJECT.options -- or for that matter, 
distinguishing between "server options" and "listener options".
While I'm at it, I think $dump_interval should be moved to $server_options,
since it is a server option.  But I won't lose sleep over these like I will
if every listening object is cruelly forced to use the same options.



Home | Subject Index | Thread Index