MOO-cows Mailing List Archive

[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

Re: [SUG] Two changes to the server

Quinn wrote:
> Let's just remove this altogether.  Make connection_name always return an
> IP and add a resolve_hostname("ip") function.  Others have suggested this
> in the past.  I'd just like something that returns either always an IP or
> always a hostname, and nothing can always return a hostname.
> Logfile readability is nice, but I'm willing to sacrifice it (using
> nslookup once and then grepping for the subnet) in favor of better
> performance and consistency.

As one who wanted this way back when I'll second the opinion.
What I think would be easiest would be to have the bfs return
IPs by default.  Then have a resolve_hostname, and a  
resolve_ip.  Not only does this affect the logs, but it
makes the {red,black,gray...}lists inffective some of the
time.  Also makes any list that stores hostnames 1.5 t 2 times
as large, etc.

Mike Thompson aka Shadow RAM : Made from 100% all natural            :          electrons!       : (UL) Listed, FCC Approved.
:      :
GCS d- s+:- a? C++++S ULU++++ P++ L++ E---- W+++ N+ o? K?
w+ O? M-- V- PS+ PE+ Y+ PGP- t+ 5- X R tv++ b++ DI+D+++ G
e- h! !r y?

Home | Subject Index | Thread Index