MOO-cows Mailing List Archive
[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]
Re: [SUG] Two changes to the server
At 02:47 PM 7/28/97 -0700, Michael Brundage wrote:
>(1) p. 71 of the Programmer's Manual points out that all server processes
>screetch to a halt while the server resolves the host name of incoming
>connections, and that this is done purely for human convenience in
>reading the log.
> Could this be turned into a compile time option
>(RESOLVE_INCOMING_CONNS or something)? It would be nice to turn off,
>especially for web serving.
Let's just remove this altogether. Make connection_name always return an
IP and add a resolve_hostname("ip") function. Others have suggested this
in the past. I'd just like something that returns either always an IP or
always a hostname, and nothing can always return a hostname.
Logfile readability is nice, but I'm willing to sacrifice it (using
nslookup once and then grepping for the subnet) in favor of better
performance and consistency.
>(2) This has been suggested before, but can we finally expunge all
>remaining vestiges of "player" from the server (replacing it with "user")?
>Dave Van Buren and I hacked this out this morning and it was pretty
>easy (not worrying about backwards compatibility; keeping backwards
>compatibility requires adding a slot in the built-in table in
This is nice in theory, but I hate to think of requiring all databases to
upgrade to the new semantics if they want any of a new server's features.
If it's backwards compatible, that's cool, but otherwise it isn't worth it.
Also, if you're going to do 'player', you may as well change 'wizard' to
'admin'. Note any LambdaCore user is still going to have $wiz_utils,
$wizard, .wizard, $player_db, $player, and so on.
In my opinion, it's more trouble than it's worth to achieve a no-nonsense
system-administrative "political correctness", but as long as it's
Ron "Quinn" Straight <http://www.netsville.com/~quinn/>
Creative Director and Senior Programmer, Netsville Inc.
Subject Index |